Jump to content


xbox 360: Since jungle update slow loading of game and icons etc.

update bugs sluggish menu

  • Please log in to reply
4 replies to this topic

Bibo1GerUk #1 Posted 13 October 2018 - 09:40 PM

    Major

  • Players
  • 23916 battles
  • 3,446
  • Member since:
    03-12-2014

Since the jungle garage update today I've had tanks, icons etc taking ages to appear. It takes 1 or 2 seconds for them to pop up. Pressing "start" for the options menu takes ages too. The M4 tank appears for ages, not just the usual "loading" icon in the bottom right hand corner. I join matches about 20-30 seconds late, I've seen other players take even longer on both servers.

I've already cleared the caches and deleted all game files on the HDD and made a complete new installation.

All to no avail. It's really annoying when the game menu is so sluggish.

Gameplay during matches is ok except for more lag spikes then usual when enemies are spotted. This particularly on EU earlier today which was basically unplayable, even causing freezes. Edit: About 18:00 CET

One more thing:

In my last match the T71 mag loadout wasn't visible until I fired a round. Only then did it show I had a mag loaded, minus 1 round of course.

Edit:

Apparently solved the sluggish menu and icon problems by deleting and then redownloading my xbox profile.

Edit2: Nope, problem still persists on EU and NA. Other players still loading late into game, menus still sluggish after multiple reinstalls of game and player profile, clearing caches etc.


Edited by Bibo1GerUk, 18 October 2018 - 10:28 PM.

Remember, it's just a game!

Gemini Rogues Youtube channel: Specific tank gameplay tips & tricks: https://www.youtube....OF8DRkA_Ml1m8vw


TBO K1LL4C4M #2 Posted 14 October 2018 - 11:27 AM

    Staff sergeant

  • Players
  • 8994 battles
  • 414
  • Member since:
    02-13-2014
Seems to be EU Server only, no Problems for me as i switched to NA. Might give it a try on NA.

Bibo1GerUk #3 Posted 14 October 2018 - 07:34 PM

    Major

  • Players
  • 23916 battles
  • 3,446
  • Member since:
    03-12-2014

View PostTBO K1LL4C4M, on 14 October 2018 - 12:27 PM, said:

Seems to be EU Server only, no Problems for me as i switched to NA. Might give it a try on NA.

 

EU crashed later according to some reports. I gave up playing after I had done about 20K XP on some tanks and got the free garage slots. What a waste of a 3x XP day.

Remember, it's just a game!

Gemini Rogues Youtube channel: Specific tank gameplay tips & tricks: https://www.youtube....OF8DRkA_Ml1m8vw


TBO K1LL4C4M #4 Posted 14 October 2018 - 09:05 PM

    Staff sergeant

  • Players
  • 8994 battles
  • 414
  • Member since:
    02-13-2014
Well i do mostly play on na anyways, except for the low Population Times, far better gaming experience.

Bibo1GerUk #5 Posted 15 October 2018 - 11:11 AM

    Major

  • Players
  • 23916 battles
  • 3,446
  • Member since:
    03-12-2014
Problem fixed. Apart from the laggy servers. Other people still joining in late or lag spikes on NA that affect everybody. One guys LT tank drove off the cliff 20 seconds into the round and according to the voice chat they had no control over it.

Edited by Bibo1GerUk, 18 October 2018 - 10:28 PM.

Remember, it's just a game!

Gemini Rogues Youtube channel: Specific tank gameplay tips & tricks: https://www.youtube....OF8DRkA_Ml1m8vw





1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users