Jump to content


Speed Demons Package missing 2 tanks


  • Please log in to reply
6 replies to this topic

Fiery #1 Posted 24 March 2020 - 10:52 PM

    First lieutenant

  • Players
  • 22277 battles
  • 620
  • Member since:
    09-29-2014

How long does it take for the other 2 tanks to show up?

I see the Vanguard but not the other 2.



Gallant Prime #2 Posted 24 March 2020 - 10:55 PM

    Major

  • WoTC Ambassador
  • 47689 battles
  • 4,395
  • [47R]
  • Member since:
    02-12-2014
Sometimes it may take a battle or relog in.  I would take a picture of your log before you log out though.  


Haukkis #3 Posted 24 March 2020 - 11:01 PM

    Major

  • Players
  • 36103 battles
  • 3,532
  • Member since:
    08-05-2015
Just play one game and those 2 tanks show up in your garage after that. Worked for me ;)

Fiery #4 Posted 24 March 2020 - 11:12 PM

    First lieutenant

  • Players
  • 22277 battles
  • 620
  • Member since:
    09-29-2014

View PostHaukkis, on 24 March 2020 - 06:01 PM, said:

Just play one game and those 2 tanks show up in your garage after that. Worked for me ;)

 

Worked thx

RFCAN76 #5 Posted 26 March 2020 - 01:21 AM

    Major

  • Players
  • 51744 battles
  • 3,364
  • Member since:
    02-13-2014
I had the same issue, sign out and sign back in The tanks were in the garage. 
"The greater the obstacle, the more glory in overcoming it."   

     Jean Baptiste Poquelin (1622 - 1673]       273 tanks in the garage as of 01/07//2020

:B  https://www.wgcommunityhub.com/gameguides

 

Spoiler Update 01/07/2020

 


tankmurdoc #6 Posted 26 March 2020 - 05:51 AM

    First lieutenant

  • Players
  • 46979 battles
  • 720
  • Member since:
    10-06-2014

View PostRFCAN76, on 25 March 2020 - 07:21 PM, said:

I had the same issue, sign out and sign back in The tanks were in the garage. 

Did the same thing today. After playing this game for 5 years I have learned all the little WG peccadillos.



MaxChaos24 #7 Posted 26 March 2020 - 10:42 AM

    Gameplay Expert

  • Administrator
  • 13668 battles
  • 21,651
  • [WGW]
  • Member since:
    09-15-2013

As the others said.

 

This issue should get fixed in our next major update. :honoring:






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users