Jump to content


Expert: USA medal

Expert USA Equalizer Premium bug Artillery

  • Please log in to reply
1 reply to this topic

Sadriel Fett-x #1 Posted 12 July 2020 - 04:53 AM

    Major

  • Beta Tester
  • 28669 battles
  • 5,346
  • [DARMY]
  • Member since:
    02-12-2014

I didn't see any other threads about this particular bug, so figured I'd post about this.  Been a while since I've played and I noticed the other day with the new Swedes and British tanks, the Expert medals for those were missing until I shoot the newly added tanks, as it supposed to be.  However, my Expert: USA medal was also missing.  I don't remember hearing anything about a new USA tech tree tank being added to the game, and when I looked on the WoT Frags website, only the new Swedes and UK tanks that I needed are showing up as required.  No USA tech tree tanks were showing as required.  

 

Today, in a match, I took out a "Premium" Tier 8 Arty tank "The Equalizer" and my Expert: USA medal popped back up.  That was the only tank I destroyed in the match, so it only could've been that particular tank.  

 

Spoiler

 

Spoiler

 

 

 

I know that "Premium Tanks" are not required for the Expert medals, so figured I'd let someone know this particular tank was causing the bug.  Thanks.

 

 

 


 

~ "I'm just a simple Fan, trying to make my way in the universe." ~

 


MaxChaos24-x #2 Posted 14 July 2020 - 05:45 PM

    Gameplay Expert

  • Administrator
  • 13932 battles
  • 22,331
  • [WGW]
  • Member since:
    09-15-2013
Thanks, we'll take a look. 




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users